Para solucionar el error headers and client library minor version mismatch que encontramos en php, simplemente tenemos que instalar los drivers para mysql de php:

apt-get install php5-mysqlnd

Una vez instalados los drivers el error “headers and client library minor version mismatch” desaparece por completo.

Este error suele aparecer despues de una actualización de php.

El driver php5-mysqlnd es el driver nativo de php para mysql.